Metric data gaps with cloud integrations

Problem

You've set up your AWS, Azure, or GCP integration and are monitoring your metrics. However, you notice gaps in your metric data charts.

Screenshot of metric data chart with gaps
This screenshot shows a metric data chart with gaps.

Solution

Here’s a list of metrics which might show gaps in your metric data. If possible, avoid setting up alerts for these metrics because we know they can generate false positives.

Amazon (AWS)
Integration Provider Event Type Metric

SNS

SnsTopic

QueueSample

provider.subscriptionsConfirmed

SnsTopic

QueueSample

provider.subscriptionsPending

SnsTopic

QueueSample

provider.subscriptionsDeleted

EFS

EfsFileSystem

BlockDeviceSample

provider.lastKnownSizeInBytes

ECS

EcsCluster

ComputeSample

provider.registeredContainerInstancesCount

EcsCluster

ComputeSample

provider.activeServicesCount

EcsCluster

ComputeSample

provider.pendingTasksCount

EcsCluster

ComputeSample

provider.runningTasksCount

EcsService

ComputeSample

provider.pendingCount

EcsService

ComputeSample

provider.runningCount

EcsService

ComputeSample

provider.desiredCount

DynamoDB

DynamoDbTable

DatastoreSample

provider.itemCount

DynamoDbTable

DatastoreSample

provider.tableSizeBytes

AutoScaling

AutoScalingInstance

AutoScalingInstanceSample

healthStatus

Billing

BillingBudget

FinanceSample

provider.actualAmount

Billingbudget

FinanceSample

provider.forecastedAmount

BillingBudget

FinanceSample

provider.limitAmount

Microsoft Azure
Integration Provider Event Type Metric

SQL

AzureSqlDatabase

AzureSqlDatabaseSample

databaseSizeCurrentBytes

AzureSqlDatabase

AzureSqlDatabaseSample

databaseSizeLimitBytes

AzureSqlServer

AzureSqlServerSample

dtuCurrent

AzureSqlServer

AzureSqlServerSample

dtuLimit

Google Cloud Platform (GCP)

We're currently reviewing the GCP metrics that can cause data gaps.

This list isn't complete. We're currently reviewing the full list of metrics that can cause data gaps.

Cause

Some metrics aren’t present in the usual cloud provider APIs (CloudWatch, Stackdriver, Azure Monitor) and are fetched from the service APIs instead. Each cloud service provider has a unique service API that processes data and interacts with the service. For example, if a metric isn’t present in AWS CloudWatch, New Relic will fetch the metric from the AWS ECS service API.

For more help

If you need more help, check out these support and learning resources: